PDA

View Full Version : CMotion gallery does not work with PVII PMM



rubin
08-03-2007, 05:28 PM
1) Script Title:

2) Script URL (on DD): http://www.lavinu.de/varia/KLsilkline_pm.htm

3) Describe problem:
Hallo,

i need some help because my CMotion gallery is not working anymore after inserting the Popup Magic Menu from Project Seven. I tested in Opera, NN, Firefox and IE and the CMotion gallery keeps working in Opera only.

I found out that the CMotion gallery is working in the other browsers if i remove the onLoad="P7_initPM(1,1,1,-20,10)" function from the body tag - what of course doesnt make sense hence this causes the PMM not to function anymore.

What can i do about this?

Here you can find my page with both the CMotion gallery and the PMM inserted.

I hope somebody can help me solving this problem.

thanks and regards, Rubin

jscheuer1
08-03-2007, 05:57 PM
Your page is in violation of Dynamic Drive's usage terms (http://www.dynamicdrive.com/notice.htm), which, among other things, state that the script credit must appear in the source code of the page(s) using the script. Please reinstate the notice first.

You have an onload conflict. Remove this:


window.onload=fillup;

from motiongallery.js and make your body tag like so:


<body background="img/layout/bgbody.jpg" id="produktseite" onload="P7_initPM(1,1,1,-20,10);fillup();" >

There could also be other problems, especially as, it shouldn't be working in Opera either, but this may just be a fluke.

rubin
08-03-2007, 07:00 PM
Hi John,

thanks a lot for your answer, everything works perfectly now - would not have been able to figure out this reason...

Rubin