PDA

View Full Version : Featured Content Slider with tag <img>



Henry_74
07-25-2007, 06:53 PM
1) Script Title:

2) Script URL (on DD): http://www.dynamicdrive.com/dynamicindex17/featuredcontentslider.htm

3) Describe problem: Hi, my problem consisted to place pictures instead of text link. How can I put the URLs of the pictures into variable declaration?

var customPaginateText=["SCHUMAG", "textlink", "textlink", "textlink", "textlink", "textlink", "textlink"]
ContentSlider("slider1","", customPaginateText)
//OR ContentSlider("slider1", 3000)
//OR ContentSlider("slider1", 3000, linktextarray)
//OR ContentSlider("slider1", 3000, linktextarray, "Foward")
//OR ContentSlider("slider1", "", linktextarray)
//OR ContentSlider("slider1", "", "", "Foward")
</script>

Thanks a lot for your suggestions..

ddadmin
07-25-2007, 08:36 PM
You can replace both the default pagination text links and the "foward" link with your own images instead by making use of the 3rd and 4th parameters of ContentSlider:


ContentSlider(slider_ID, [autorotate_time], [custlinktext], [customnextlinktext])

For example:


var linktext=["<img src='1.gif' />", "<img src='2.gif' />", "<img src='3.gif' />", "<img src='4.gif' />"]
var nexttext="<img src='forward.gif' />"
ContentSlider("slider1", 5000, linktext, nexttext) //Auto rotate slider with custom pagination and "Next" links text

That should do it.

Henry_74
07-26-2007, 05:22 AM
Thanks for yuor answer but it doesn't work, the pictures don't appear...


var linktext=["<img src='1.jpeg' />", "<img src='2.jpeg' />", "<img src='3.jpeg' />", "<img src='4.jpeg' />", "<img src='5.jpeg' />", "<img src='6.jpeg' />, "<img src='7.jpeg' />]
ContentSlider("slider1","", linktext)
</script>

browser show an error JS:

previsto ']'

ddadmin
07-26-2007, 08:33 AM
It does work. There's an error in the way you defined linktext:


var linktext=["<img src='1.jpeg' />", "<img src='2.jpeg' />", "<img src='3.jpeg' />", "<img src='4.jpeg' />", "<img src='5.jpeg' />", "<img src='6.jpeg' />, "<img src='7.jpeg' />"]

You're missing the last apostrophe (") at the very end.

Henry_74
07-26-2007, 10:58 AM
ddadmin now the links show squares with inside a red cross, but slides works correctly! Why the pictures don't appears? :(

ddadmin
07-26-2007, 11:41 AM
Make sure the paths to the images specified in your <img> tags are valid, ie: "1.jpeg".

Henry_74
07-26-2007, 05:53 PM
Ok ddad, thanks

jpayne04
08-17-2007, 10:01 PM
I've got it up and running on a demo site here (http://ascensiondove.com/clients/fbc) but I'm having a hard time with the css. What I would like to do is have the images/links faded (opacity set low) and then when rotated to that image for the next div the image is fully visible (opacity 100&#37;).

I know it has to be in the css somewhere and that I'm messing up somehow on the coding (btw, have not done the php include that will have dd's link in it yet).

Thanks for any help you can give me,

Jonathan