PDA

View Full Version : AJAX Tabs Content Script - Problem with IE, ON same domain!



bijanv
07-23-2007, 04:49 PM
1) Script Title: Ajax Tabs Content Script

2) Script URL (on DD): http://www.dynamicdrive.com/dynamicindex17/ajaxtabscontent/

3) Describe problem: If you guys have a look here (www.dgglobal.ca/sites/S1/index.php?p=6) using IE and you click on the tab, you will see that it loads for a second before loading completely on a seperate page.

I've been searching through the forums and it seems the cause of this problem is that the external files aren't on the same domain however in my case they are on the same domain and this is still hapening!

I've also made that change to the Javascript that was recommended in a couple of threads and still no help.

If you need my code please let me know but I would be grateful if anyone could help!

ddadmin
07-24-2007, 12:57 AM
Hmmm at a glance everything looks in order. This doesn't have anything to do with whether IE thinks the external pages are off domain, as in those cases it simply won't load the specified page, whether in the content DIV or as its own page. It looks like something else on your page is cancelling out the "onclick" event handler that's dynamically assigned to each of the tabs when the page loads. To confirm if the problem could be one of your other scripts on the page, try temporarily removing them:


<script type="text/javascript" src="http://www.dgglobal.ca/IMPACT/JsScripts/stdJavascripts.js"></script>
<script type="text/javascript" src="http://www.dgglobal.ca/IMPACT/JsScripts/x_core.js"></script>
<script type="text/javascript" src="http://www.dgglobal.ca/IMPACT/JsScripts/x_event.js"></script>
<script type="text/javascript" src="http://www.dgglobal.ca/IMPACT/JsScripts/x_window.js"></script>
<script type="text/javascript" src="http://www.dgglobal.ca/IMPACT/JsScripts/x_dom.js"></script>
<script type="text/javascript" src="http://www.dgglobal.ca/IMPACT/JsScripts/cal.js"></script>

<script type="text/javascript" src="http://www.dgglobal.ca/IMPACT/JsScripts/en/cal_conf.js"></script>

BTW, please note that your page is currently in violation of our usage terms, since the credit notice doesn't appear inline on the page. Please reinstate the credit notice:

bijanv
07-24-2007, 05:06 PM
oh sorry. I'm not sure where the credit is or should be displayed, if you could point that out to me I'd put that back. It might be a problem with our CMS that removes it or doesn't display it.

I'm trying to see if those scripts can be removed or not. For this page they're not being used but I also can't reach them as it seems to be built into the CMS that I don't have access to.

I'll get back to you on if I can fix them or not, is there anyway to get around this problem without disabling them though?

Thanks for your help!