PDA

View Full Version : Drop Down/Overlapping Script not working in Firefox



bman
07-22-2007, 06:41 PM
1) Script Title: Drop Down/Overlapping Content

2) Script URL (on DD): http://www.dynamicdrive.com/dynamicindex5/overlapcontent.htm

3) Describe problem: I was just informed by one of my viewers that the script is not functioning in Firefox. Since I use IE, and don't have Firefox, I can't check it out.

Here's one of the pages (http://www.FlaCarShows.com/ne.htm) where the script is being used, although it's being used in ALL the Event Pages.

As always, any help would be appreciated.

Barry

ddadmin
07-23-2007, 07:21 AM
Looks like a z-index problem. Try moving all your sub content DIVs outside the table so they're not nested, for example, right above the </body> tag of your page. The sub content DIVs are ones like the below:


<DIV id="subcontent15" class="event">
"
"
</DIV>

BTW, please note that your page is currently in violation of our usage terms, since the credit notice doesn't appear inline on the page. Please reinstate the credit notice:

bman
07-23-2007, 10:54 AM
First, thanks for the fix! Removing the <DIV>'s from the table fixed the Firefox problem.

Second, I apologize for the credit notice. It DOES appear on the script, but I didn't transfer it to all the pages it's being used on.

As I work on updating each page, removing the DIV's from the table, I'll add the credit notice. It was never my intent to try and hide it from anyone, and again, I apologize.

bman
07-23-2007, 02:06 PM
Well, I thought it was fixed! Now, according to someone using Firefox, when a link is clicked, what appears is the header and footer of the DIV (with the proper yellow background), but the text shows up with just a white background, making it impossible to read.

Again, I don't have Firefox, so I can't actually view it. I would appreciate it if someone who uses Firefox would view this page (http://www.flacarshows.com/central.htm), and hopefully be able to tell me why it isn't displaying properly.

I REALLY DO appreciate the help on this!

ddadmin
07-24-2007, 12:15 AM
Hi:
I checked all your .css files, and as I suspected, you have a "height" attribute defined for the .event class that's causing the problem. Inside FCSstyle.css, find the following block of code:


.event {
position: absolute;
display: none;
border: 2px solid black;
background-color: FFFFC0;
height: 35px;
width: 400px;
padding: 8px;
font-family: Verdana, Arial, Sans Serif;
font-size: 11px;
}

You need to remove the line in red.

bman
07-26-2007, 01:34 AM
Thank you...it's fixed. A copy-and-paste screwup by me!