PDA

View Full Version : Working Lightbox 2.0 withing Ajaxtabs?



typhoidtimmy
07-13-2007, 03:59 PM
1) Script Title: Ajaxtabs & Lightbox 2.03

2) Script URL (on DD):
http://www.dynamicdrive.com/dynamicindex17/ajaxtabscontent/index.htm
http://www.dynamicdrive.com/dynamicindex4/lightbox2/index.htm

3) Describe problem:
I was trying to tie in the Lightbox 2.0 script withing the ajaxtabs display pages but cannot get them to work correctly. I tried both to load the javascripts on the outer pages and within the html calls by the tab but they seem to be clashing with each other.

I do know the Lightbox script does work because I displayed the html page outside the ajaxtabs and it worked correctly so we know that the cause of the error is the ajaxtab.

My example test page can be seen here:
test page (http://s53962.sites85.storefront-hosting.com/Traditional%20Saunas/Portable%20Saunas/Polar%20Two%20Piece%20Portable%20Sauna/polartest.aspx)

Clicking the picture tab you can see where the 3 images tests are sitting at the top. These are the Lightbox testers.

Any help would be greatly appreciated....Thank you:D

jscheuer1
07-13-2007, 06:45 PM
See:

http://www.dynamicdrive.com/forums/showthread.php?t=17426

typhoidtimmy
07-13-2007, 11:16 PM
Lovely write up and that did the trick to get it to work correctly.

Except now I have found that the borders are going wonky in FF.

IE works fine but Firefox is not rolling the border out correctly.

Think its related to this?

Thank you for your help

jscheuer1
07-14-2007, 12:54 AM
I'd try removing the link to the lightbox scripts and style from the external page(s). Also, make sure you haven't edited lightbox.css, or if you have, save a copy of your edited version and start over with a fresh copy, changing just one thing at a time to find what particular change FF may not like.