PDA

View Full Version : Tab Content Script help



jgoodman09
06-18-2007, 08:05 PM
1) Script Title: Tab Content Script

2) Script URL (on DD): http://www.dynamicdrive.com/dynamicindex17/tabcontent.htm

3) Describe problem: class="selected" is not working for me. in ie and firefox, it loads all tabs at once. after i refresh, i works great. here is the link: http://www.cfr.msstate.edu/test/summit/

any help would be greatly appriciated.

by the way, your site is awesome, i was amazed to find a site with so many good scripts.

- john

switt
06-25-2007, 08:50 PM
1) Script Title: Tab Content Script

2) Script URL (on DD): http://www.dynamicdrive.com/dynamici...tabcontent.htm

3) Describe problem: class="selected" is not working for me.

4) my URL: http://www.meanpony.com/phpmod/template06.php


Despite setting the selected class option for the 1st tab & using
the persistence default in the .js file, no tabs open to content on
initial load of the page. (only tab headings appear w/ empty content box)

Clicking any tab does open the content boxes correctly.

Any clues or browser reports of bugs using FF & Safari?

thanx in advance,
sWitt

ddadmin
06-25-2007, 09:27 PM
Switt:
There's an error in your tab menu list HTML, specifically, the last one:


<li class=""></li>

It should not be empty like above. Either remove it, or add to it the missing portions inside it (<a> tag).

Vespa808
06-26-2007, 06:46 AM
Hi guys, great site, fantastic resource, thanks for all the good work.

On the tab content script, how do you get the tabs to appear vertically down the left hand side instead of horizontally?

Cheers

V808

ddadmin
06-26-2007, 06:52 AM
how do you get the tabs to appear vertically down the left hand side instead of horizontally?

Please start a new thread when asking your own question about a script on DD. To your question, there's no "roadmap" to doing this. You can certainly try playing around with the CSS for the tabs, and replace the text inside each tab with a graphic that's flipped vertically instead.

Vespa808
06-26-2007, 07:02 AM
Thanks so much, I will try playing with it and see what I can manage. I'll be sure and post a new thread if I can't do it though.

Cheers

switt
07-05-2007, 11:37 PM
thanks,

missed the empty HTML tag, your suggestion solved the prob.

sWitt @ meanpony