PDA

View Full Version : FrogJS Image Gallery



farmwife
06-12-2007, 08:06 PM
1) Script Title: FrogJS Image Gallery

2) Script URL (on DD): http://www.dynamicdrive.com/dynamicindex4/frogjs/index.htm

3) Describe problem:

Link to the page the script is on: http://www.briarpatchkennel.com/pic1.html

I tried removing all the "descriptions or notes in this script as I just want the pictures, but see what I get?

What did I do wrong?

Also, I downloaded and saved the Frogjs.js file and uploaded the .js files in ascii, is that correct?

Veronica
06-12-2007, 08:59 PM
It looks as if your editing program might have made some changes, converting special characters < and >.

In your browser, open your html page, go to View > Source and you'll see:



&lt;script type="text/javascript" src="scripts/prototype.js"&gt;&lt;/script&gt;
&lt;script type="text/javascript" src="scripts/scriptaculous.js?load=effects"&gt;&lt;/script&gt;

&lt;script type="text/javascript" src="scripts/frog.js"&gt;&lt;/script&gt;

&lt;style type="text/css"&gt;
#FrogJS{
width: 760px;
height: 600px;
margin: 0 auto;
}
#FrogJSCredit{
text-align: right;
font-size: 80&#37;;
color: #999;
padding: 1px;
}
#FrogJSCaption{
text-align: left;
line-height: 140%;
}
&lt;/style&gt;


That needs to be



<script type="text/javascript" src="prototype.js"></script>
<script type="text/javascript" src="scriptaculous.js?load=effects"></script>
<script type="text/javascript" src="frog.js"></script>

<style type="text/css">
#FrogJS{
width: 760px;
height: 600px;
margin: 0 auto;
}
#FrogJSCredit{
text-align: right;
font-size: 80%;
color: #999;
padding: 1px;
}
#FrogJSCaption{
text-align: left;
line-height: 140%;
}
</style>


Open the html file on your hard drive in a text program like Notepad. Replace the bad code with what I've provided. Then re-upload your html file. The way you uploaded it is fine.

Also note, that you put the js files into the same directory as your html files. The way I re-wrote your html will work that way. If you move the js files to a nother directory, your path would need to change.

farmwife
06-13-2007, 01:29 PM
You guys are great!!!! Thanks for the help!

The only thing I'm seeing now, is that when I first go to the page the script is on, it is really wide at first until you click on the first thumbnail? Any idea why?

Veronica
06-13-2007, 02:27 PM
I've looked at it in IE and FF, and it looks OK. It goes right to the slideshow and is only as wide as it needs to be to display the large picture.