PDA

View Full Version : Description not showing in thumbnail viewer



keithz
05-25-2007, 08:31 PM
1) Script Title: thumbnailviewer

2) Script URL (on DD): http://www.dynamicdrive.com/dynamicindex4/thumbnail.htm

3) Describe problem:
When I click on a thumbnail, the original photo pops up as it should, but the description does not show. I have checked my coding and it is correct. Here is an example of the code:

<a href="photos/cfalls925.jpg" rel="thumbnail" title="Copper Falls State Park, Wisconsin"><img src="photos/cfalls925.jpg" style="width: 100px; height: 80px" /></a>

The description only shows on the thumbnail image just like the alt parm shows in the img tag, but not it does not show in the popup window. I have checked the js code and option enableTitle: has a value of true.

Any help as to what is going on and what to do to correct this would be greatly appreciated. I plan to use this script for several galleries on the next version of my website.

Thanks

keithz

ddadmin
05-26-2007, 03:28 AM
Warning: Please include a link to the DD script in question in your post. See this thread (http://www.dynamicdrive.com/forums/showthread.php?t=6) for the proper posting format when asking a question.

jscheuer1
05-26-2007, 06:18 AM
There could be many reasons. A link to your problem page would help narrow things down. What pops into my mind though is that style(s) on and/or linked to the page are combining in such a way that, although the text is there, it cannot be seen. This could be due to - say, white text on a white background - something like that or positioning via margins, padding, or top property/value pairs that put the description behind something. If it is same colored text on same colored background, you should be able to see the text by dragging the mouse over (selecting) it or by selecting all for the page from the browser's edit menu.

keithz
05-27-2007, 12:43 AM
Thanks John,

I didn't realize the text for the description was the same color as I was using as my default. I changed the default and all is well.

I am really looking forward to getting version 3 of my site up and running utilizing this script.

keithz :D