PDA

View Full Version : Lightbox v2.03 in Firefox



Mardus
05-11-2007, 08:01 PM
1) Script Title: Lightbox v2.03

2) Script URL (on DD): http://dynamicdrive.com/dynamicindex4/lightbox2/index.htm

3) Describe problem:

Hi

In Firefox the "close x" image is located right on the edge of the lightbox, but I would like it to be 10-15px from the right edge, equally with the edge of the image. How do I achieve it? It's a small problem, but still, disturbs my eye. And it's weird, because the DynamicDrive sample is all OK, just on my page... I add an image in case if needed for better understanding:
http://i114.photobucket.com/albums/n259/syrrealist/lightbox.jpg


Thanks in advance,
M.

jscheuer1
05-12-2007, 05:56 AM
That's not where it is on the demo page in FF here. Unless you are seeing it there on the demo page in FF there, it is something you did in your implementation or something already existing on your page interacting with the script and/or (most likely) its styles. It could even be something as simple as forgetting to specify px in your stylesheet.

If you do see it that way in FF on the demo page, it is something to do with your version of and/or setup of FF.

So, which is it?

If it is your implementation or conflict with your existing page, we would need a link to your page in order to be of specific help.

Mardus
05-12-2007, 01:00 PM
That's the thing, I did not change any padding/margin values in the codes, only customized url to the images (in lightbox.css and lightbox.js ), which seems to be ok since the images are found and displayed, just a little in the wrong place. Or maybe the url's are the problem? Or directories?

I viewed the DynamicDrive original examples with the same Firefox 2.0.

Okay, the example gallery is here (http://www.zone.ee/xiii/gallery/2204/).
(ignore the first page and click http://i114.photobucket.com/albums/n259/syrrealist/zone.jpg to go to the destination page. Free host, you know, sorry.)

Take a look and tell me what do you think.


M.

jscheuer1
05-12-2007, 02:29 PM
Here it is:


a img {
border-width: 0;
padding: 10px;
}

from your on page stylesheet. You need to make this specific to the gallery of thumbnails, like:


.content a img {
border-width: 0;
padding: 10px;
}

Mardus
05-12-2007, 03:06 PM
Okay, that totally solved the issue! Big thanks, jscheuer!