PDA

View Full Version : Image Thumbnail Viewer II with slideshow



ackscott
05-04-2007, 06:58 AM
1) Script Title: Image Thumbnail Viewer II

2) Script URL (on DD): http://www.dynamicdrive.com/dynamicindex4/thumbnail2.htm

3) Describe problem: Thanks for the great scripts and help! I got this script to work on my site, but I was wondering if there is a way to have a slide show (with fades) of the enlarged images playing until the user mouses over one of the thumbnails, stopping the slide show and showing the enlargement of the thumbnail. The page would then function like the script is currently written.
Thanks!

jscheuer1
05-04-2007, 03:48 PM
I was able to set up a demo of this using TVII and:

Swiss Army Image slideshow (http://www.dynamicdrive.com/dynamicindex14/swissarmy/index.htm)

I had to modify swissarmy.js slightly. You can download that modified script here (right click, save as swissarmy.js):

http://home.comcast.net/~jscheuer1/side/files/swissarmy.js

Here is a link to the demo:

http://home.comcast.net/~jscheuer1/side/files/thumb_swiss.htm

You can use your browser's view source to see its code.

ackscott
05-07-2007, 05:50 PM
I finally got your script to work after a few frustrations. I didn't have the first line of code:
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/1999/REC-html401-19991224/loose.dtd">
I guess that's key.
Thanks for your great site and your help!
Scott

SoulieBaby
08-08-2008, 05:12 AM
Hey there

I'm using the slideshow mod for the Image Thumbnail Viewer II as well as the active thumbnail highlight mod I found on another thread (but changing the bg instead of the border color) anyway I was wondering how I could combine the two, so when the slideshow is running, the thumbnail picture automatically highlights also..

http://www.shadowcaddy.snapsite.com.au/clubs.php is the site I'm working on, if you put your mouse over the little squares at the bottom of the page, you'll see the highlight working..

Basically I want that to work for the slideshow too.. If you view the source code you'll see what I'm using to get it to work..

Also just another question, how do I get the fade to work in FF/Safari etc, I believe it's using:


var filterstring="progid:DXImageTransform.Microsoft.GradientWipe(GradientSize=1.0 Duration=0.7)"

Which doesn't work in anything else other than IE..

If someone could help me out, that would be fantastic! :)

SoulieBaby
08-08-2008, 05:22 AM
Oh and I forgot to say, I'm using this version of the Image Thumbnail Viewer..

http://home.comcast.net/~jscheuer1/side/files/thumb2.htm

(if that makes any difference?)