PDA

View Full Version : cmotion gallery problem



ishred
04-24-2007, 06:46 PM
1) Script Title: motiongallery2

2) Script URL (on DD): http://www.dynamicdrive.com/dynamicindex4/cmotiongallery2.htm

3) Describe problem:

http://www.omegatattoo.com/features.html

the problem is in FiF with the position. It has Absolute positioning, but I need it to be inside the table to the left of the iFrame. When I remove the absolute positioning, the script no longer functions (ie. it doesn't scroll).

Help...anyone?

jscheuer1
04-25-2007, 01:13 AM
There are a number of problems with your page. And, the position of the gallery isn't absolute but, you have somehow made it so. It would take some time to list all of the problems but, fixing just these two will give you a big improvement (from your source code - additions/changes red):


<div id="motioncontainer" style="width:125px; height:500px; overflow:hidden; position: relative;">
<div id="motiongallery" style="position:absolute; left:0; top:0;">

ishred
04-25-2007, 02:59 AM
i didn't modify the code or anything, just cut and paste.

I'll try what you suggest and report the results tomorrow.

Thanks

jscheuer1
04-25-2007, 03:07 AM
i didn't modify the code or anything, just cut and paste.

Right, and the cat ate my homework. I really don't care if you edit the heck out of the code or not. I'm just telling you two important problems I saw, problems that were not in the demo code.

The changes I proposed worked fine here with a local copy of your page. If you need more help with them, you know where to post. Good luck with your site!

ishred
04-25-2007, 01:40 PM
I was being totally serious....

you even said my site has a bunch of issues, which probably means i'm in no position to be editing someones code.

thanks again.

ishred
04-25-2007, 11:54 PM
Hi John,

I made the changes that you suggested. It did move the gallery to the correct place, except now it does not scroll.

any ideas?

I really appreciate the help.

jscheuer1
04-26-2007, 06:32 AM
Yes, follow instructions. Now you've made another change that no one (I know of) told you to make. You've changed:


<div id="motiongallery" style="position:absolute; left:0; top:0;">

to:


<div id="motiongallery" style="position:relative;">

Change it back to:


<div id="motiongallery" style="position:absolute; left:0; top:0;">

Leave the rest alone and it will now work and stay where it is supposed to be.

ishred
04-26-2007, 02:09 PM
thanks john.

do you take donations for your work?

jscheuer1
04-26-2007, 02:51 PM
thanks john.

do you take donations for your work?

You're welcome. You can email me an Amazon.com gift certificate if you like or donate to one of the charities in my tag line.