PDA

View Full Version : need some help pls



karin
04-14-2007, 01:54 AM
1) Script Title: Conveyer Belt Slideshow

2) Script URL (on DD): http://www.dynamicdrive.com/dynamicindex14/leftrightslide.htm

3) Describe problem: Great slideshow script! But only in IE it leaves a gap between the last and first picture......how can i fix that?

Karin

thetestingsite
04-14-2007, 01:59 AM
Not sure what you mean; but when you view the demo script (on Dynamic Drive), is there a "gap" between the images there as well? If so, try editting this line in the code:




//Specify pixels gap between each slideshow rotation (use integer):
var slideshowgap=5


Change the part in red to a lower number until you get the result you are looking for. However, if it does not do the same thing as on your page, a link back to your problem page would be useful to us (so that we can troubleshoot the problem.

Hope this helps.

karin
04-14-2007, 06:43 AM
thanks for you reply, i aligned the script center, that doenst work in IE (its fine in opera and FF) so in IE the script has to be aligned left.
karin

jscheuer1
04-14-2007, 12:01 PM
When you use align="center", it gets tricky in IE, especially with scripts like conveyor. In IE, instead of putting an element around the show with align="center", edit the script here:


document.write('<table align="center" border="0" cellspacing="0" cellpadding="0"><td>')

Or, if you are using a DOCTYPE that causes IE to use standards or 'almost standards' mode, you can center it by using style in a containing element of the same width as the slide show and margin:0 auto; (for the demo slider that has a width of 300px):


<div style="width:300px;margin:0 auto;">
slide show script goes here
</div>