PDA

View Full Version : Simple Tree Menu icons missing when in another folder



spiff
04-03-2007, 12:20 PM
Script: Simple Tree Menu
http://www.dynamicdrive.com/dynamicindex1/navigate1.htm

1) Script Title: Simple Tree Menu

2) Script URL (on DD): http://www.dynamicdrive.com/dynamicindex1/navigate1.htm

3) Describe problem: :

I am trying to use Simple Tree Menu as the navigational menu for a website and am having problems getting the icons to appear on every page. I have placed the images and scripts in a folder called "navmenus" (e.g. www.mysite.com/navmenus). Throughout the site, I have used folders to organise my content.

On index.html at the root level (e.g. www.mysite.com/index.html), the icons (list, open, close) work fine. I use dreamweaver templates to create the other pages, but when I use the Simple Tree Menu to go to another page (e.g. www.mysite.com/faq/index.html), the icons for open in the Simple Tree menu do not appear. It only affects the links which I have opened. The icons for close still work.

Is this a problem with the parsing of the file? Which file? ANy ideas? I'm guessing it's the .js file It also appears that I cannot edit the .js file and force the urls to become absolute urls (I thought this might be a solution).

Has anyone encountered this problem? Is there any solution to this problem?

Thanks.

spiff
04-04-2007, 07:34 AM
Hmm. thanks to another developer i know, the problem has been fixed.

It involves specifying an absolute path in the .js file, from the server root.
what i was doing previously was trying what i though was an absolute , but it was only from my site root, as opposed to the server root.