PDA

View Full Version : Please help! Flash is driven me crazy



tombino
03-27-2007, 08:16 AM
1) Script Title:
Lightbox image viewer 2.0

2) Script URL (on DD):
http://www.dynamicdrive.com/dynamicindex4/lightbox2/index.htm

3) Describe problem:
I have a .asp page with a flash animation. The image thumbnail appear not at front. Everything else in the page is darker (like should be) except for the flash animation that come out at front covering my image... How can I solve this problem??
Thanks!

Tombino

jscheuer1
03-27-2007, 01:31 PM
Follow the detailed information at:

http://www.macromedia.com/cfusion/knowledgebase/index.cfm?id=tn_14201

Or, if this short version (good in most cases) fixes it, so much the better! Add in this language to your object/embed tag:

Add the following parameter to the OBJECT tag:

<param name="wmode" value="transparent">

Add the following attribute to the EMBED tag:

wmode="transparent"

If you are using script to generate the tags (as is frequently done to avoid the 'click to activate' feature in some browsers), the wmode transparent must be passed to the script. This is easily accomplished but, varies depending upon the sort of script one uses. Some scripts do it automatically.

tombino
03-28-2007, 08:06 AM
Hi John,
I tryed your short version and work perfectly.
Many Thanks, you solved my problem!

Tombino

tombino
03-29-2007, 12:07 AM
HI John,

When I hold my cursor over my flash animation the selection box over laps the image, and come out this sentence.
"click to activate and use this control".
Of course if I click the problem is gone.

any ideas on how to fix this?
Thanks

Tombino

jscheuer1
03-29-2007, 01:27 AM
I would need a link to your page or at least see the code for the Flash tags to be specific. But, the basic concept is to write the tags to the page using an external script. Let's say you have Flash tags like so:


<object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=8,0,0,0" width="362" height="287">
<param name="wmode" value="transparent">
<param name="movie" value="some.swf">
<param name="quality" value="high">
<embed src="some.swf" quality="high" width="362" height="287" wmode="transparent" type="application/x-shockwave-flash" pluginspage="http://www.macromedia.com/go/getflashplayer">
</embed></object>

You make up an external file called - say, flash_swf.js and put this in it:


document.write('<object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=8,0,0,0" width="362" height="287">\
<param name="wmode" value="transparent">\
<param name="movie" value="some.swf">\
<param name="quality" value="high">\
<embed src="some.swf" quality="high" width="362" height="287" wmode="transparent" type="application/x-shockwave-flash" pluginspage="http://www.macromedia.com/go/getflashplayer">\
<\/embed><\/object>');

Notice the added \'s at the ends of all but the last line plus the added \'s before the /'s in the close tags. Save it to the same folder as the HTML page. Once you have your Flash tags replicated via script in this manner, you can then replace them on your HTML page with:


<noscript>
<object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=8,0,0,0" width="362" height="287">
<param name="wmode" value="transparent">
<param name="movie" value="some.swf">
<param name="quality" value="high">
<embed src="some.swf" quality="high" width="362" height="287" wmode="transparent" type="application/x-shockwave-flash" pluginspage="http://www.macromedia.com/go/getflashplayer">
</embed></object>
</noscript>
<script src="flash_swf.js" type="text/javascript"></script>

That's the general idea but of course, you must use the code from your tags.

tombino
04-01-2007, 10:51 PM
Hi john,

I tryed but doesn t work. I give you the link of my website

http://www.loveloveclothing.com.au/

I think what I need is to automatic activate flash documents. The work computer is not activated, so for interract with my flash animation I have to click in to it, but in the home compuer work fine, without clicking.

In the top animation I have insered the transparent line that you gave me, if I do the same think with the animation in the midle of the page go very slow. But check the website for understand better. My english is not the best...

Thanks,
Tom

tombino
04-01-2007, 11:48 PM
My mistake, work fine!!! Thank you.

But the problem with adding the transarent tag remain. Go slower.

Regards,
Tom

jscheuer1
04-02-2007, 05:37 AM
On your page, put this:


. . . <td valign="top">
<noscript>
<object classid="clsid:D27CDB6E-AE6D-11CF-96B8-444553540000" id="obj1" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,40,0" border="0" width="770" height="500">
<param name="movie" value="floating_bg1.swf">
<param name="quality" value="high">
<param name="wmode" value="transparent">
<embed src="floating_bg1.swf" wmode="transparent" quality="high" width="770" height="500" type="application/x-shockwave-flash" pluginspage="http://www.macromedia.com/go/getflashplayer">
</embed></object>
</noscript>
<script src="flash_swf.js" type="text/javascript"></script>
<p align="center"> . . .

In flash_swf.js put this:


document.write('<object classid="clsid:D27CDB6E-AE6D-11CF-96B8-444553540000" id="obj1" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,40,0" border="0" width="770" height="500">\
<param name="movie" value="floating_bg1.swf">\
<param name="quality" value="high">\
<param name="wmode" value="transparent">\
<embed src="floating_bg1.swf" wmode="transparent" quality="high" width="770" height="500" type="application/x-shockwave-flash" pluginspage="http://www.macromedia.com/go/getflashplayer">\
<\/embed><\/object>');

tombino
04-02-2007, 07:02 AM
I understand what s wrong.
The background of my flash animation is empty, so in the transparent mode the mouse will answer just where the objects are. This is beacause sometime the mouse didnt go. I think I have just fill the last layer in my .fla
I will try.

Thanks.

tombino

jscheuer1
04-02-2007, 02:14 PM
You could also try adding a:


<param name="bgcolor" value="#ff9933">

tag to the object tag and a:


bgcolor="#ff9933"

attribute to the embed tag.

tombino
04-06-2007, 08:24 AM
Hi,
i just tested the website in Mozilla firefox. The image viewer doesnt work and the flash animation doesn come out. In explorer 6.0 is working fine. What can I do??

please help!!!

Regards,
TOm

jscheuer1
04-07-2007, 05:20 AM
Well, I'm not all that surprised but, your page works here. I think you may have javascript disabled in FF. Try following my instructions a little more closely, particularly post #8 from this thread.

tombino
04-10-2007, 02:17 AM
hi John,

sorry in the last post i wrote "The image viewer doesnt work and the flash animation doesn come out" but actually just the image viewer script doesnt work in firefox. The flash animation work fine.

regards,
Tombino

jscheuer1
04-10-2007, 04:02 AM
Works fine here. My FF browser has Flash v 9 installed. Perhaps you have a version prior to 8.

tombino
04-12-2007, 07:00 AM
this is strange, I already tryed in 3 different pc and didn t work. But flash shouldnt be important. The javascript should work fine. Did you try to open "enlarge" a image?

Thanks,
Tom