View Full Version : Password Authentification not sure if I am doing this correctly

02-24-2007, 02:33 AM
1) Script Title:
Password Authentification
2) Script URL (on DD):
3) Describe problem:
I am using Dreamweaver MX and I am trying to create so that when a user goes to my webpage they have to enter a username and password to view the rest of the site.
I went to the above script and created in notepad a file named .htaccess and inside this text file is the following code:

AuthName "Restricted Area"
AuthType Basic
AuthUserFile www.neuzel.com/.htpasswd
AuthGroupFile /dev/null
require valid-user

I then created in notepad another text file called .htpasswd and inside that text file is the following text:



Part of my problem is I am not sure what to put for this line:
AuthUserFile www.neuzel.com/.htpasswd

my website is www.neuzel.com. It is being hosted by GoDaddy so I am really not sure what my exact path is. I know it should look something like: /home/site_name/. But I am not sure what should go in the "home" spot.
I think in the site_name should be "www.neuzel.com" Is that right??

Ok, after I created these two text files I uploaded them to my GoDaddy account. Am I suppose to create any type of form fields for them. I thought I could create these files and then it would be like a Windows prompt???

Thank you for your help. I do not know very much eccept the basics of HTML coding. But just a little of that. So long-drawn-out explinations are great! :)


02-28-2008, 05:13 PM
I actually have the same question. I feel so bad asking about it, because I feel I should be better at coding, being on this site. :)

I also have the same question about this: e.g. - /home/site_name/ I also have a Godaddy hosting account. I got this from the generator (but I am sure it's wrong):

AuthName "Restricted Area"
AuthType Basic
AuthUserFile /bronteyork.us/Pass/.htpasswd
AuthGroupFile /dev/null
require valid-user

I named the two files htpasswd and htaccess
I created a file "Pass" and put it just under the Root directory, which is called "bronteyork"

Also, I understand that no .txt should be in the file, but I have set my Folder option to hide the txt extension, but after uploading it still shows. Not sure how to get rid of that, either. I think I did it. I renamed it in GoDaddy, and the txt is gone. It is still not working. What am I doing wrong?

I uploaded both files by FTP, no problem with that, but no sign in box comes up. :(

Any help would be apprecited. I know I screwed up somewhere, just don't know where.