PDA

View Full Version : Script not working after moving site.



farmwife
02-15-2007, 06:56 PM
1) Script Title: Flexi Slideshow

2) Script URL (on DD): http://www.dynamicdrive.com/dynamicindex14/flexislide.htm

3) Describe problem:

I have had to move the site from one server to another and now the script isn't working. I haven't changed the nameservers yet, could that be why? I didn't think this would cause a script not to work as I have another script that IS working.

To get to the site, the url is: http://70.86.235.2/~damaxken/index.html

Can anyone help?

jscheuer1
02-15-2007, 08:11 PM
That could be the problem, yes. These things affect different code in different ways. It is the path to files (image files in this case) that is important.

The way you have the script configured:


variableslide[0]=['/images/slide1.jpg', '', '']
variableslide[1]=['/images/slide2.jpg', '', '']
variableslide[2]=['/images/slide3.jpg', '', '']
variableslide[3]=['/images/slide4.jpg', '', '']
variableslide[4]=['/images/slide5.jpg', '', '']

It expects to see the images here:


http://70.86.235.2/images/slide#.jpg

But, they are really here:


http://70.86.235.2/~damaxken/images/slide#.jpg

You could change your code to:


variableslide[0]=['images/slide1.jpg', '', '']
variableslide[1]=['images/slide2.jpg', '', '']
variableslide[2]=['images/slide3.jpg', '', '']
variableslide[3]=['images/slide4.jpg', '', '']
variableslide[4]=['images/slide5.jpg', '', '']

Or, you could use the absolute path to the images, ex:


variableslide[1]=['http://70.86.235.2/~damaxken/images/slide2.jpg', '', '']

Once you have a DNS, depending upon how the paths work out, you might be able to go back to your old code.