PDA

View Full Version : help with multiple scripts



pubcrawler13
02-07-2007, 04:28 PM
1) Script Title: Scrollable Content II / Presentational Slideshow

2) Script URL (on DD): http://www.dynamicdrive.com/dynamicindex11/scrollc2.htm
http://www.dynamicdrive.com/dynamicindex14/presentationslide.htm

3) Describe problem:

Hi guys,
I'm trying to incorporate the above two scripts into a page I'm working on. Let me preface this by saying up front that I have taken the advice given here on the site for incorporating two or more scripts on one page using the 'body onload' trick to no avail - more on that in a sec. Anyway, he's the issue:

I've got the first script (Scrollable Content) in the left column and the second one (Presentational Slideshow) in the right column of a single table. Individually the scripts work fine, but when I put them both in, the 'scroll up/down' function of the first script ceases to work, while the whole of the Presentation script continues to work just fine. As I said, I did check the official notification on how to incorporate multiple scripts into one page by combining the functions in the <body> tag. I found [window.onload=getcontent_height] in the first script and [window.onload=startit] in the second, so I commented them both out and modified the body tag to read <body onload="getcontent_height();startit()">. After doing this and testing it live in Firefox, both script worked perfectly, exactly as I had hoped. However, in IE, the first script works perfectly but the second script not only doesn't work but doesn't display at all, as if there were nothing there.

If anyone has any idea what might be causing this I would greatly appreciate some input. I hope the description was clear enough - feel free to hit me up for further clarification.

Thanks!
Andy

EDIT: here's a link to the page: http://www.nationwidepaymentsolutions.com/NEW/index2.html (The problem script has been commented out entirely but it's still there - just view the source to see it)

bzmhmommy
03-27-2007, 06:02 AM
I apologize upfront for replying without anything helpful to add. But I just wanted to tell you I'm having the same sort of problem. I can't get 2 scripts to work on the same page. I'm trying a hover button effect together with a top navigation bar script. Separately they work fine. But together they both stop functioning. I've searched for the information you alluded to in your post about combining the functions in the body tag...but I haven't found it. So I'm not even sure how to go about trying that out. I'll keep searching. And I'll keep checking back here to see if anyone can help you out with your problem. Good luck!

-Julie