View Full Version : Featured Content Slider not showing up in Firefox

02-06-2007, 09:50 AM
1) Script Title: Featured Content Slider

2) Script URL (on DD): http://www.dynamicdrive.com/dynamicindex17/featuredcontentslider.htm

3) Describe problem: I was able to set up the Featured Content Slider to work on IE, but I cannot get it to show any images on Firefox. I've tried it on Firefox versions, 1.5.09 & I read through the past posts, hoping to find a solution, but the closest I found was a reference to adding a loder tag, which I couldn't find. Here is the url of my page: http://inet4adventure.com/scroller.htm

Any help is greatly appreciated.

02-06-2007, 11:06 AM
<link rel="stylesheet" type="text/css" href="mainstyle.css">

The above mentioned css file is not available.

I got the following error , screenshot has been attached.

Make sure that the CSS files are ok

02-06-2007, 11:15 AM
Good catch. I just uploaded the mainstyle.css but unfortunately it didn't help. I still can't display images in Firefox.

02-06-2007, 11:28 AM
I'm not sure what the problem is exactly. There appears to be something amiss with this file:


The error in FF is:

Error: The stylesheet http://inet4adventure.com/contentslider.css was not loaded because its MIME type, "text/plain", is not "text/css".
Source File: http://inet4adventure.com/scroller.htm
Line: 0

And, now that you've uploaded the other missing stylesheet I am also getting:

Error: The stylesheet http://inet4adventure.com/mainstyle.css was not loaded because its MIME type, "text/plain", is not "text/css".
Source File: http://inet4adventure.com/scroller.htm
Line: 0

This makes me think that there is something wrong with the permissions set on the files or on the directory or with the method of transfer. When you uploaded the css files, what method of transfer did you use? Do you know what permissions are set for these files?

It could be something else but, it is not the code in the .htm file.

02-06-2007, 11:37 AM
I've just saved http://inet4adventure.com/scroller.htm using Firefox and instead of mainstyle.css I got two files

mainstyle.htm(l) - an html based page

Are you sure that you saved your CSS file with an extension of .CSS?

You can do it from your side also John try to save his page from Firefox and look at the associated files (pages) downloads along with the page.

02-06-2007, 11:43 AM
I think that's just the way FF sees the files as served. You can navigate directly to:


If its extension were incorrect, that shouldn't be possible. That is what makes me think that it is the permissions or the transfer protocol used. Of course, if that is not the extension on the server, that would probably be the problem.

Added later:


Is a 404 file not found, so it is not the extension. I'm really thinking xfer protocol but, it could be something else, like permissions or something I'm not seeing.

02-06-2007, 12:33 PM
Well that's interesting. I checked the permissions on the server and they are at the default values of: rw-rw-r-- for User, Group, World, respectively.

I uploaded the files using the ftp feature in Dreamweaver 6.0 and redited the .css files in notepad (saving with default settings) as a double check. Usually I edit .css files with editplus (http://www.editplus.com/). - Don't know if that would help anyway.

John, I'm willing to send you the logins to the site if you're curious to try uploading. You can email me direct at: jason_s_00 (at) hotmail.com.

What else could it be?


02-06-2007, 03:11 PM
It could be the server itself. Is this a new host? Have you used external css files successfully with it in the past? Are they supposed to go in a certain directory? By xfer protocol I meant binary or text/ASCII. I think binary would be better. Also, if your host has one of those online uploading utilities as many do, I would try deleting the css files and then uploading them again with that utility, just to see what happens.

Feel free to PM me an FTP address, username, password (anything else required by your host for FTP) so that I can snoop around.

02-07-2007, 02:29 AM
Hi John,

I'm going to send you the logins for some proper snooping. In the meantime, I tried uploading the .css files through the provided control panel, but the files were named with the entire path from my computer (sucky control panel). I had to rename them through the Dreamweaver ftp. The only difference that I could tell was the permissions were now rw-r--r-- (instead of rw-rw-r--). And, the slider still doesn't work in Firefox.

02-07-2007, 10:57 PM

I followed the advice here (also quoted below):


Bug Fix: My CSS (cascading style sheets) show up and function in IE but not in Firefox or Opera, How can I fix this.

Resolution: this bug occurs because of a missing mime type in the mime.types file on the web server, if you validate your CSS you will come up with this error:

I/O Error: Unknown mime type : text/plain

These are the following steps will fix this:

1. navigate to the directory /www/conf

2. vi or pico the mime.type file

3. add this line: text/css css

4. restart the web server

note: there is another file in the /etc directory , changing this one will not solve this issue.

PS: if you dont have access to the /www/conf/mime.type file , please contact your CI Host tech support or you can take matters in your own hands by adding a .htaccess file in the directory that has your CSS files. these are the following steps:

1. vi or pico .htaccess

2. add this line:
AddType text/css .css
3. save , clear web browser cache and restart, the view the webpage again

Except I created an .htaccess file and uploaded it via FTP.

02-08-2007, 01:35 AM
You are the man. Thanks John!