PDA

View Full Version : CMotion Image Gallery Top Alignment



rmarable
01-24-2007, 03:14 PM
1) Script Title: CMotion Image Gallery

2) Script URL (on DD): http://www.dynamicdrive.com/dynamicindex4/cmotiongallery.htm

3) Describe problem: I have tried different parameters to change the spacing above the images that scroll here...
http://innercitistorm.com
Everything I have tried continues to leave a large gap at the top of the scroll. Can someone please help. Thanks in advance!

jscheuer1
01-24-2007, 04:16 PM
Your markup as generated for the browser is seriously flawed. Not being familiar with aspx, I'm not sure as to how exactly to advise you but, you cannot have span elements like this:


<span id="dnn_ctr436_XModDisplay_dlXMods__ctl0" nowrap="nowrap" valign="top">

<!-- This part goes into the template header (in the "Configure XMod Module" settings -->

<div id="motioncontainer" style="vertical-align:top;overflow:hidden;height:400;width:100%">
<div id="motiongallery" style="position:absolute;left:0;top:0;white-space:nowrap;">

<table id="trueContainer" cellpadding="5"><tr></span>

or this:


</td>

</span><br><span id="dnn_ctr436_XModDisplay_dlXMods__ctl2" valign="top">


<!-- this part goes into the list template itself -->

<td align="center" valign="top"><a href="http://barbquefest.com" target="_blank"><img src="/Portals/0/Portfolio/bbq_little.jpg" style="height:120px;"><br><b>Bar-B-Que Fest.com</b></a></td>

</span>

chopping up the code for your table and other elements. There are many of these misplaced spans. Also, some of the <br> tags (like the blue one above) are outside of the table cells, can't have that either.

Once you fix all that, set your style for the motioncontainer like so:


<div id="motioncontainer" style="position:relative;overflow:hidden;height:160px;width:100%">