PDA

View Full Version : Ajax Tabs Content - Weird issue with IE7



pfulton
01-17-2007, 09:57 PM
1) Script Title: Ajax Tabs Content script

2) Script URL (on DD): http://dynamicdrive.com/dynamicindex17/tabcontent.htm

3) Describe problem: I'm having a strange issue when testing my site out in IE7...unfortunately.

Here's the situation, the script works very well across all other browsers that I've tested it in, including IE6, Firefox 2.0.0.1, Opera 9.02, and Safari.

When clicking on a tab in IE7, the tab opens in its own page, rather than inside the tab container. If you're running IE7 (and I pray that the admins are or can get to a machine that is), you can check out the issue here:
http://www.pittsburghlive.com. I've modified the look of the tabs a bit, but you'll notice that in the tan or main area there is a large search space. Below that are two tabs, one that says "search" and another that says "your town".

If you click on your town, you get directed into the new window.

If you have any thoughts on how I can remedy this, please let me know.

Thanks in advance for your help!

jscheuer1
01-18-2007, 05:08 AM
Worked fine here in IE 7. It has been noted elsewhere that due to improvements in IE 7, this script usually will not work locally in that browser.

pfulton
01-18-2007, 02:55 PM
Interesting that it worked fine for you...which is definitely good news for me! I guess I'll just forge ahead and put up some other tabs and hope for the best.

Thanks!

pfulton
01-19-2007, 03:59 PM
I've discovered what the problem was, and it was my error and not anything relating to the script.

On the script page, you'll notice that there is a note stating: Reminder: Due to security limitations, the external pages loaded via each tab must be from the same domain as the Content Tabs page itself...

The site that I was working on has several mirrors, and I was working from the first mirror in the stack. Because the external file I was calling was technically from a different domain (the url was pointing to a different mirror), the script was throwing one of the tabs into its own page.

So, I'll reiterate again: the problem has been solved...this was all due to my error and not an error in the script itself.

Mods/Admins: you can delete this thread if you feel necessary.

Thanks again for the great site!

tam_18
08-23-2007, 08:49 AM
Hi

I downloaded the ajax tabs content zipped folder and extracted files. I haven't changed any items in the folder, nor did I move any files around. So as it stand - the demo and external files are all in the same folder with the ajaxtabs folder sitting in this containing the images, css and .js.

When I opened demo.htm in IE7 - the tabs opens the links into the same page replacing the demo.htm page and does not pull the external page into the content area of the tab.

I uninstalled IE7 and now I am running IE6 - the exact same file works perfectly. Any thoughts on this? Need to use this asap.

regards.
Tam

jscheuer1
08-23-2007, 11:07 AM
Worked fine here in IE 7. It has been noted elsewhere that due to improvements in IE 7, this script usually will not work locally in that browser.

It will work just fine live in IE 7 though.

snegny
09-08-2007, 12:53 AM
I am 100% sure that everything on my site located on the same server, but still it loads external page in IE7.

Let alone my server, even when I go to http://www.dynamicdrive.com/dynamicindex17/ajaxtabscontent/ and try Demo tabs in EI7 it leads to external page like http://www.dynamicdrive.com/dynamicindex17/ajaxtabscontent/external3.htm.

:( :confused:

snegny
09-22-2007, 07:11 AM
will this problem be seriously addressed?

ddadmin
09-22-2007, 07:51 AM
will this problem be seriously addressed?

The issues mentioned by the other posters in this thread have actually all been resolved. The first person discovered an error on his own page, the other was running the script offline in IE7 (it must be run online).

jscheuer1
09-22-2007, 08:48 AM
I am 100% sure that everything on my site located on the same server, but still it loads external page in IE7.

Let alone my server, even when I go to http://www.dynamicdrive.com/dynamicindex17/ajaxtabscontent/ and try Demo tabs in EI7 it leads to external page like http://www.dynamicdrive.com/dynamicindex17/ajaxtabscontent/external3.htm.

:( :confused:

That being the case, that even the demo on Dynamic Drive here is not working for you in IE 7, there is most likely some (probably security/custom or advanced) setting in your copy of IE 7 that prevents it from working.