PDA

View Full Version : doesn't work in IE; works fine in Mozilla



karine
02-05-2005, 03:11 PM
Hi
This is a great site. Have used it many times in the past few years, but this is my first post. I'm using several scripts on a page. I read the rules, but I'm asking for a pointer in the right direction and not a solution. The problem is: All scripts work fine in Mozilla. BUT not in IE. In IE, two of the scripts stop displaying when the third script is introduced. (and I have tried an alternate third script, too. Same "stop functioning" in IE only.)

Can you just point me in the right direction to check stuff as to why IE isn't working? I don't need a full solution (although I wouldn't turn it down). Just some hints about why IE may not working (when Mozilla is fine).

staging page: http://ns.cdyn.com/bossradio/listening/index1.html
scripts used on every page of site successfully in IE and Mozilla:
1. Dynfader (in the header graphic): http://dynamicdrive.com/dynamicindex2/fader.htm
2. HV Menu (black row with red subpages):
http://www.dynamicdrive.com/dynamicindex1/hvmenu/

third script (I've tried two different 3rd scripts with the same result of stoppage in IE only):
3a. Typing Scroller:
http://www.dynamicdrive.com/dynamicindex2/typescroll.htm
3b. Cross Browser Marquee:
http://www.dynamicdrive.com/dynamicindex2/cmarquee.htm

I've disabled Dynfader, trying to keep HV Menu and one of the third scripts. IE still not working. So I'm thinking the problem is with HV Menu and any third script. Although HV Menu and Dynfader work on all other pages of the site in both IE and Mozilla; it's only when I introduce a third script that IE breaks.

What's making IE sensitive?

Karine

karine
02-05-2005, 03:24 PM
forgot to mention....

I checked variables and no duplication.
HV Menu and third scripts do use "document.write." Is this a problem in IE?

Karine