PDA

View Full Version : Problem with lightbox2.02 and ID



PeetyPablo
12-07-2006, 07:58 PM
1) Script Title: lightbox2.02

2) Script URL (on DD): http://www.dynamicdrive.com/dynamicindex4/lightbox2/index.htm

3) Describe problem:
http://www.oplevverden.nu/rejse.asp?rejseoplevelser=69

I have a problem with lightbox 2.0. It works sometimes, but when clicking next i the "gallery" third time normally doesnt work. It says I have an error in the code. It seems like it doesnt like my numbers in the URL.

Is there anything to do??

Thanks
Peter

jscheuer1
12-08-2006, 07:44 AM
All but one of your larger images appears to be missing or configured improperly, all I get its the loading icon for the 2nd thru the 6th images when clicked.

PeetyPablo
12-08-2006, 09:09 AM
Yeah. But the problem is more when you wish to view all with clicking next. Then some of them only show the loading. Thats pretty strange.

Can it have something to do with my URL string? rejse.asp?rejseoplevelser=69

?

Thanks for your help
Peter

jscheuer1
12-08-2006, 05:45 PM
Ah, I see a real problem and a minor problem, there could be others. This script:


<script language="JavaScript1.2" type="text/javascript">

window.focus();

var slideshow_width='780px' //SET IMAGE WIDTH
var slideshow_height='168px' //SET IMAGE HEIGHT
var pause=4500 //SET PAUSE BETWEEN SLIDE (3000=3 seconds)

var fadeimages=new Array()
//SET 1) IMAGE PATHS, 2) optional link, 3), optional link target:

fadeimages[0]=["banner14.jpg", "", ""] //plain image syntax
fadeimages[1]=["banner16.jpg", "", ""] //plain image syntax
fadeimages[2]=["bann . . .

Is outdated and looks like a DD script without the credit, a violation of DD use policy (http://www.dynamicdrive.com/notice.htm). The missing credit is the minor problem. Lightbox (by the way) is an exception to this use policy, ddadmin has told me that since lightbox is third party and the author hasn't inserted a credit on the calling pages, that's fine with him. The real problem is that the fading slide script is outdated. You should use (usage is different than the old version you have):

http://www.dynamicdrive.com/dynamicindex14/fadeinslideshow.htm

instead or, better yet, this version (which I've modded for better xbrowser compliance - usage is the same as the above linked DD library script):

http://www.dynamicdrive.com/forums/showpost.php?p=64522&postcount=2

In any event, the problem caused by the version you are using is that it defines the variable pause globally. That same variable was defined globally by lightbox but, by the time it goes to use it, it is no longer available as lightbox had defined it.

The updated fade script will fix this because its variables are local, not global.

PeetyPablo
12-15-2006, 09:12 AM
Thanks m8. Nice of you to answer me.

I will insert credit and try the new script.

Thanks again
Peter