PDA

View Full Version : HV Menu v5.5 problems



Frost
01-30-2005, 06:48 AM
Ok, I've read the rules of posting but I still need help with this one. I've got the script to basically work. I'm usiing it in two frames, a leftNav frame and a main frame where all my pages are to load.

Problem is, I've used the default links that are in the menu just to test the menu. (abc new, etc.) When I click on a link it opens up in my main navigation window, but once the page is opened, the menu stops working. Submenus no longer appear.

Any ideas? Below is my index page with my frameset, and the variables I changed in the exmplmenu_var.js file:

<FRAMESET framespacing=0 rows=97,20,*,17,25>

<FRAME name="logo" frameborder=0 marginWidth=0 marginHeight=0 src="header.htm" noResize scrolling=no>
<FRAME name="header" frameborder=0 marginWidth=0 marginHeight=0 src="topMenu.htm" noResize scrolling=no>

<FRAMESET cols=165,*,25>
<FRAME name="leftNav" frameborder=0 marginWidth=0 marginHeight=0 src="leftNav.htm" noResize scrolling=no>
<FRAME name="main" frameborder=0 marginWidth=0 marginHeight=0 src="content.htm">
<FRAME name="leftFrame" frameborder=0 marginWidth=0 marginHeight=0 src="leftFrame.htm">
</FRAMESET>

<FRAME name="top_footer" frameborder=0 marginWidth=0 marginHeight=0 src="footer_files/top_footer.htm" noResize scrolling=no>
<FRAME name="bottom_footer" frameborder=0 marginWidth=0 marginHeight=0 src="footer_files/bottom_footer.htm" noResize scrolling=no >

</FRAMESET>

exmplmenu_var.js:

var MenuFramesVertical=1; // Frames in cols or rows 1 or 0
var DissapearDelay=1000; // delay before menu folds in
var TakeOverBgColor=0; // Menu frame takes over background color subitem frame
var FirstLineFrame='leftNav'; // Frame where first level appears
var SecLineFrame='main'; // Frame where sub levels appear
var DocTargetFrame='main'; // Frame where target documents appear
var TargetLoc=''; // span id for relative positioning

Any help would be greatly appreciated.