PDA

View Full Version : Switch Content-script works slowly in IE



nosilkcut
01-25-2005, 08:36 PM
I'm using the Switch Content-script in a page that has about 200 expand/switch-contents. In Netscape there is no problem - but in Explorer the page freezes whenever the user leaves the page and returns to it! It is not server-related as the same thing happens when testing on my local machine.

However there's no problem with the funtionality of the opening/closing of the content. - It is leaving and returning to the page which takes forever.

Is there anything (hopefully something simple) I can do to speed this script up without having to reduce the amount of "expand/switch"-div's ???

thanks for any help.

christina

cr3ative
01-25-2005, 09:29 PM
This might be something to do with the way Netscape and IE handle the cache.

I'm guessing that IE is re-checking the data when you click Back, causing it to sift through a lot of information.

Then again, I might be totally wrong; just my two cents.

cr3ative

nosilkcut
01-25-2005, 09:43 PM
Thanks for the reply.
Then there might not be much I can do about it....hmm...

ddadmin
02-01-2005, 12:44 AM
When creating this script, we had to strike a balance between efficiency and use of implementation. A lot of the process as far as implementing the script is automated, though as a result, the script scans the page completely to put everything in place. If you're using a lot of switches (200 certainly would quality), then I can see a problem with efficiency developing. Unfortunately I don't have the time at the moment to re-examine the script to see what can be done, though I'm noting it for future development.