PDA

View Full Version : HV Question



shortchick
01-19-2005, 07:06 AM
Script: http://www.dynamicdrive.com/dynamicindex1/hvmenu/index.htm

HI.

I know DD did not write this script but I'm hoping SOMEONE might have some ideas on what is happening on my site.

I have the menu horitzontal, with the "StartLeft=0;" which according to the comments is the "offset y coordinate". Now on some of my pages, the menu is flush against the left but on other pages, it is not.

For example:
http://www.royaltyrecords.ca/services.html THIS PAGE IS NOT FLUSH WITH THE GREEN BAR ABOVE (ie. not right against the table)

WHEREAS
http://www.royaltyrecords.ca/tours.html THIS PAGE IS *ALMOST* FLUSH WITH THE GREEN BAR (ie. right against the table)

Any ideas?

Thanks!

simonf
01-19-2005, 09:31 AM
Hi

Try changing the file secondmenu_var.js line 29

was: var StartTop=100; // Menu offset x coordinate

to: var StartTop=96; // Menu offset x coordinate

I did this and both seem to be snug and look OK.

shortchick
01-19-2005, 04:16 PM
HI Simon,

Thanks for that, but unfortunately that move the menu up not to the left. I am trying to get the left side of the red menu bar to line up with the left side of the green bar.

Thanks.

Minos
01-20-2005, 05:09 AM
The issue is the sizing of your pages...as soon as you jump onto a page that requires a vertical scrollbar, the table jumps to left a tad so that it remains centered. The menu does not. At least this explains it, I'll try to find a solution, if someone else doesn't have a quick one.

shortchick
01-20-2005, 06:03 PM
minos,

After playing with it for yet another several hours I know it is with the layout of the menu vs the main table. I have tried playing with the pixels but I sitll haven't gotten it figured out.

Some really strange behaviour...
- one person can click "refresh" and the menu will lign up properly.
- when I load it, the tours and news pages come up properly but none of the other pages (not even if I hit refresh)

Any help you could give me would be appriciated!

One last thing... my table is set to be 750 pixels and yet the first row of spacers adds up to 757 pixels. How does HTML handle that? Which setting does it ignore? (Based on my testing I think it goes with the table setting, but then that leads to the question, where does it cut out the 7 pixels??) Are these the same 7 pixels that are causing the problem???

Thanks! :eek: