View Full Version : Advanced RSS Ticker script cannot read FeedBurner feed

09-30-2006, 07:09 PM
1) Script Title:

Advanced RSS Ticker

2) Script URL (on DD):


3) Describe problem:

I have used the Advanced RSS Ticker for a while to read/parse a FeedBurner RSS feed I have set up for a blog I have on Blogger. The FeedBurner feed is located at http://feeds.feedburner.com/paris-frequently-asked-questions.

The ticker was working just fine up til today when it suddenly stopped working and gives me the following error:

"Error fetching remote RSS feed!
Sorry, no items found in the RSS file :-("

No updates were made to the site or the ticker files. To do a bit of testing, I replaced the FeedBurner feed with the CNN feed that comes with the demo, and the ticker started working again.

That leads me to believe that something changed in the format of the FeedBurner feed somehow, but looking at http://feeds.feedburner.com/paris-frequently-asked-questions, I see nothing out of whack.

Can someone please have a look and provide me with some help?

Any help is much appreciated.

01-12-2007, 06:17 AM
I searched the posts, and I'm having the same problem.

The Advanced RSS Ticker worked fine with FeedBurner until Blogger went into Beta and they changed some things. I think the problem is with the posting dates. The blogger atom/rss feeds now use <published> instead of <pubDate> which the ticker files use. Are there any workarounds for this or other ways to convert a blogger feed to work with the ticker? I tried switching all the <pubDate> references in the rssticker.js, lastRSS.php, and bridge.php files to <published> and it doesn't work.

02-19-2007, 10:48 AM
I am having the same problem -- feedburner feeds are now kaput.

I would very much appreciate advice on getting around this problem with this otherwise-superb tool.

I have posted a link to this thread (http://forums.feedburner.com/viewtopic.php?p=37967#37967) in the Feedburner forum --

02-19-2007, 11:43 AM
I'll try and load up a feedburner feed later today to confirm the problem. I can't speak for Feedburner as far as whether the format of their RSS feeds have changed that's the cause here, though the backend RSS parser used by this script (LastRSS (http://lastrss.oslab.net/)) hasn't been modifed at any point.

p.s: Please only use the "Thank User" feature when you wish to thank a user for a helpful post, typically a helpful response to your question. I see you've thanked both users above that are merely asking a similar question as yours, which isn't appropriate.

02-19-2007, 10:49 PM
Thanks for your prompt response --

The BBC feed in the example continues to work just fine.

http://feeds.feedburner.com/cinematech stopped working a few weeks ago.

I wonder whether it might be possible to use another, more recently minted feed parser, such as SimplePie (http://simplepie.org/)? There is a discussion about this on the SimplePie forum (http://simplepie.org/support/viewtopic.php?id=683).

02-20-2007, 02:25 AM
I haven't had time yet to load up the RSS ticker with a feedburner feed, but I'll update this thread once I do.

Regarding Simplepie, it is definitely more robust than LastRSS, and if you have the time, you could always try installing RSS Display Boxes (http://www.dynamicdrive.com/dynamicindex18/rssdisplaybox/index.htm), and see if your feedburner feed shows up correctly. It should take less than 5 minutes. FYI on my to-do list is to eventually migrate to SimpiePie for the RSS scrollers here on DD (there are 2).

02-20-2007, 08:06 AM
Ok, I've just test run a couple of different feedburner RSS feeds- one works, though yours doesn't. What version of RSS is your feed? LastRSS works with 0.9, 1.0 and 2.0, though not other feed types such as Atom. Simpiepie does.

02-21-2007, 05:23 AM
The way I got mine to work was to use the atom feed in Feedburner, and then the Feedburner url in the ticker.

Go to Optimize and Convert Format Burner and set it to RSS 2.0. The timezone is still off on mine, since Feedburner is in the Central timezone.