PDA

View Full Version : Anylink Drop Down z-index and flash file



pixelsherpa
08-21-2006, 05:06 AM
1) Postioning the Anylink Drop Down menu to drop down OVER a flash movie

2) Script URL (on DD): http://www.dynamicdrive.com/dynamicindex1/dropmenuindex.htm

3) I noticed the menu code assumes a z-index of 99, assuming it would automatically drop down over any other objects. But in my layout it displays UNDER a flash file i have positioned in a table cell just below.

The menu correctly drops down ABOVE the flash movie in all browsers on a mac, and Firefox on PC but not IE on PC

test site: http://test.getwirelessllc.com/

Any tips/hacks to solve this problem?

thanks

jscheuer1
08-21-2006, 08:53 AM
Follow the detailed information at:

http://www.macromedia.com/cfusion/knowledgebase/index.cfm?id=tn_14201

Or, if this short version (good in most cases) fixes it, so much the better! Add in this language to your object/embed tag:

Add the following parameter to the OBJECT tag:

<param name="wmode" value="transparent">

Add the following attribute to the EMBED tag:

wmode="transparent"

pixelsherpa
08-21-2006, 04:21 PM
thanks for the reply - I will try it but am unsure. In the past i have used the transparent param in cases where the background color of the HTML could be assumed instead of the flash movie background, but in this case the backgrounds of the flash movie are jpgs, required for imagery that rotates.

The transparent param also affects performance in some cases which i would prefer not to risk on this.

I appreciate your help and will give it a whirl

It seems there should be some z-index workaround that may be more effective / efficient? Anyone?

pixelsherpa
08-22-2006, 01:36 AM
Follow the detailed information at:

http://www.macromedia.com/cfusion/knowledgebase/index.cfm?id=tn_14201

Or, if this short version (good in most cases) fixes it, so much the better! Add in this language to your object/embed tag:

Add the following parameter to the OBJECT tag:

<param name="wmode" value="transparent">

Add the following attribute to the EMBED tag:

wmode="transparent"

Success - in IE on the PC at least. Thanks John, despite my uncertainty your advice worked!
The object tag mod fixed for IE/PC and the EMBED tag mod fixed for Firefox PC