View Full Version : Highlight Table Cells Script FireFox quirky

08-15-2006, 03:40 AM
I tried using the "Highlight Table Cells Script" from this site and it seems a bit quirky in FireFox. After mouse over event ........ if you don't exit vertically the highlighting stays. Has anyone experienced simular problems; or know of any fix.

08-15-2006, 07:11 AM
This really belongs in the Dynamic Drive Scripts Help forum. But, don't worry too much about that, the moderator will move it if he sees fit. However, we would really appreciate a link to the script here on DD that you are referring to. It would help us to help you. Also, if you have your version live, a link to that page would be helpful as well.

08-15-2006, 07:16 AM
I think I found the script that you are talking about:


If that's the one, I'm not seeing any problems like what you say you are experiencing with it. I'm using FF and looking at the above link, the highlight disappears no matter how my mouse exits the cells.

08-15-2006, 05:06 PM

That is a link to a place that I moved a test file out of my DEV environment. It seems what causes problems is rolling over the input fields.

08-15-2006, 05:31 PM
Well, there is an error:

uOnLoad is undefined

That pops up as the page loads. That can't be good. It does look like the form elements are somehow taking focus away from the table elements and since they are so close together (vertically), if the mouse is moved fast enough, it doesn't have time to register that it is passing over the table before encountering another form element. I'll have a closer look at this when I have more time.

08-15-2006, 06:03 PM
Much Appreciated!

08-16-2006, 05:19 AM
There are many things wrong with your demo. Many of the scripts linked to it are not there. Script calls on it reference functions that are missing. Element id's that are just a single number are present (id's must begin with a letter). There are invalid comments, ex:


There needs to be spaces, like so:

<!-- GBTDTAG -->

Element names beginning with underscores (gotta be letters).

None of these is likely to be the culprit, however and there are probably other errors of this type. These type of errors make it hard to be certain what's up with the page though. Try validating (http://validator.w3.org/) your code as you go along.

Here is the one error I cannot seem to shake:

Error: uncaught exception: Permission denied to get property HTMLDivElement.parentNode

and I cannot find the division that it is talking about. But, here is the function that causes it:

function contains_ns6(master, slave) { //check if slave is contained by master
while (slave&&slave.parentNode)
if ((slave = slave.parentNode) == master)
return true;
return false;

I found that by changing the above to:

function contains_ns6(master, slave) { //check if slave is contained by master

return false;


It seemed to fix it but, this might cause other problems.

08-16-2006, 06:41 PM
Thank you ..... that worked really well.