PDA

View Full Version : Flickering scrollbar with Image Thumbnail Viewer



monique
08-06-2006, 08:10 PM
1) Script Title: Image Thumbnail Viewer II

2) Script URL (on DD): http://www.dynamicdrive.com/dynamicindex4/thumbnail2.htm

3) Describe problem:

Again on the new website I am developping (but now another page) occurs a prpblem after installing the a.m. viewer. See: http://www.arti-mo.com/nieuw/kunstenaars.htm - also for the code, since this is too long to place here...

The problem is that the scrollbar on the right side of the field with all the names "flickers" when moving the mouse over the various items :rolleyes: Sorry, don't know any other word to use better for this 'defect'.

Does anyone know what causes this problem and how it can be solved?

Thanks very much :)

Monique

boogyman
08-06-2006, 08:44 PM
#tekst a:hover {
text-decoration:underline;
font-weight:normal;
color:#845ba9;
}




#tekst a:hover {
text-decoration:underline;
font-weight:normal;
color:#845ba9;
scrollbar-face-color:#c2adbc;
scrollbar-highlight-color:#ede2f7;
scrollbar-3dlight-color:#ffffff;
scrollbar-darkshadow-color:#845ba9;
scrollbar-shadow-color:#ffffff;
scrollbar-arrow-color:#845ba9;
scrollbar-track-color:#ede2f7;
}


you needed to add your scroll bar attributes to the hover class you use for the links...

monique
08-24-2006, 11:16 AM
Sorry for my late reply - didn't realize my thread was in the wrong forum and had been moved to another forum - understand now there is a dedicated forum for DDS-help!

Thanks for your advice Pissa. I tried this, but unfortunately it didn't help. The scrollbar still flickers when moving the mouse over the names.

Does anyone know a better solution?

Thanks,
Monique

monique
08-28-2006, 06:44 AM
One more remark on this problem from my part: this problem only occurs with IE, not with NS, FF or Opera.

Hope someone can help me please :confused:

Monique

jscheuer1
08-28-2006, 07:22 AM
Disable (remove) the transition filter on the images, that will clear it up in IE. These IE only transitions often cause problems like this.

Get rid of the red parts:


function modifyimage(loadarea, imgindex){
if (document.getElementById){
var imgobj=document.getElementById(loadarea)
if (imgobj.filters && window.createPopup){
imgobj.style.filter=filterstring
imgobj.filters[0].Apply()
}
imgobj.innerHTML=returnimgcode(dynimages[imgindex])
if (imgobj.filters && window.createPopup)
imgobj.filters[0].Play()
return false
}
}

monique
08-28-2006, 11:05 AM
I checked this (offline) and it now works perfect John! :D

Thanks a lot :)

Monique