PDA

View Full Version : Conveyor Belt imagegap issue-problem



nant
08-02-2006, 05:50 AM
1) Script Title: Conveyor Belt slideshow script

2) Script URL (on DD): http://www.dynamicdrive.com/dynamicindex14/leftrightslide.htm

3) Describe problem:

I have been trying to create a slideshow with no gap between images.
I have read relevant posts regarding the code:

//Specify gap between each image (use HTML):
var imagegap=" "

I have been setting this variable to null ("") or '' and I always seem to get a gap between images.

Am I doing something wrong?

jscheuer1
08-02-2006, 07:26 AM
Set it like so:


//Specify gap between each image (use HTML):
var imagegap=""

That's with no space between the quotes. Also, were you have images in your array like this (from the demo):


leftrightslide[0]='<a href="http://"><img src="dynamicbook1.gif" border="0"></a>'

Use zero for the border (the default coding in the demo uses border=1).

Finally, if you want as little spacing as the script allows, set this value:


//Specify pixels gap between each slideshow rotation (use integer):
var slideshowgap=0

to zero as shown (default in the demo is 5). This last value only affects the space between each full train of images though (each time the images start to repeat). It has nothing to do with the gap between each individual image.

___________________

Notes:


<a href="http://">

is bad form. It really is just a place holder in the demo. Either replace it with a real link or use:


<a href="javascript:void(0);">

Or remove the:


<a href="http://">

and the:


</a>

if no link is what you really want.

CoenX
05-26-2008, 10:12 AM
To create (almost) perfect no gap loop:


var imagegap=""
var slideshowgap=-3

(Try loping the same image multiple times, for better result, as done here (http://www.shift-f16.nl/brochures.html))