PDA

View Full Version : image w/desrcription tool tip & image maps



cbrillow
07-30-2006, 06:06 PM
1) Script Title: image w/description tooltip

2) Script URL (on DD): http://www.dynamicdrive.com/dynamicindex4/imagetooltip.htm

3) Describe problem:

I've been trying to use the image w/description tooptip script with an image map, and am not having any luck. I was happy to find this thread:

http://www.dynamicdrive.com/forums/showthread.php?t=6909&highlight=image+description

but am still unable to find the problem with my implementation. Mousing over the live areas in the map causes the cursor to change to the link cursor, indicating that it's finding the correct area of the map, but the images do not display.

Here's a link to a site that illustrates the situation.

http://mywebpages.comcast.net/ths69/imgtemp/mapwork_20th_popup_img.html


This is a greatly simplified test, to be expanded and completed when/if I'm able to display the images correctly.

Note: in the example, only the 1st, 2nd & 4th people, starting at the left end of the front row, have live areas.

I'm new to this site and forum, and am very grateful for the service and any help you might be able to provide. Thanks!

jscheuer1
07-30-2006, 09:29 PM
Script conflict. Here's how to get it to avoid the conflict - remove this from the script:


window.onload = initTip;

Add this (red) to the body tag's onload event:


onLoad="init();initTip();"

Also, the script doesn't work in Opera 9 at all, though it could.

jscheuer1
07-30-2006, 09:37 PM
To get the script to work in Opera, find these lines near the top and add the red parts:


var ns5 = ((window.opera||navigator.userAgent.indexOf("Gecko")>-1) && dom) ? true: false;
var ie5 = ((navigator.userAgent.indexOf("MSIE")>-1) && dom &&!window.opera) ? true : false;

cbrillow
07-31-2006, 02:23 AM
Thanks very much for your suggestions -- I'll give it a shot first thing in the morning!

(Edit) Heck, you went to the trouble of helping -- least I could do is to stay up a few more minutes and try it... And it worked! (haven't implemented the Opera fix yet...)


Thanks again.