PDA

View Full Version : dynamic ajax content bug in MSIE?



Swiffer
07-10-2006, 12:17 AM
1) Script Title: 'Dynamic Ajax Content'

2) Script URL (on DD): http://www.dynamicdrive.com/dynamicindex17/ajaxcontent.htm

3) Describe problem:

Hi everyone,

I'm implementing Dynamic Drive's 'Dynamic Ajax Content' code into a webpage. It works great on every browser except on MSIE 6.0.

This is the page that is giving me an error:
http://www.americanbabies.net/v3/news.html

The error is:
Error: 'document.getElementByld[...]' is null or not an object

On other browsers like Safari, the "news" content page automatically loads. On MSIE, it is blank beneath the menu and I receive this error. I must click the "news" link to have the 'news' content appear, even though I installed the script to have this automatically load.

Any help will be very much appreciated!!

Thanks,
Adam

benslayton
07-10-2006, 02:43 AM
Sorry, but not to be too harsh or anything. I believe the DD terms of use say that you have to keep credit notice:

/***********************************************
* Dynamic Ajax Content- Dynamic Drive DHTML code library (www.dynamicdrive.com)
* This notice MUST stay intact for legal use
* Visit Dynamic Drive at http://www.dynamicdrive.com/ for full source code
***********************************************/

http://dynamicdrive.com/notice.htm

Swiffer
07-10-2006, 03:00 AM
thanks for the tip, the disclaimer is now inserted.

jscheuer1
07-10-2006, 05:41 AM
This:


<script type="text/javascript">
ajaxpage('first.html', 'contentarea')
</script>

needs to go after this:


<div id="contentarea"></div>

Swiffer
07-10-2006, 12:11 PM
again, thank you!