PDA

View Full Version : AnyLink CSS Menu- IE is ignoring my CSS



StaceyB
06-30-2006, 08:04 PM
am am using a div for a menu dropdown with an image. I set the class surrounding the image to 'Link1' but it keeps showing the blue link box (changes to purple after visited) around my images with the dropdown. I have set my css to the same color as the images and I no longer see the link box in Firefox but IE is ignoring my css. How can I get the box to disapper in IE?

My CSS:
a.Link1:link { color: #9C9C08; text-decoration: none; }
a.Link1:visited { color: #9C9C08; text-decoration: none; }
a.Link1:hover { color: #9C9C08; text-decoration: none; cursor: pointer; }
a.Link1:active { color: #9C9C08; text-decoration: none;

Here's the link. Notice difference in browsers.
http://www.sidconcepts.com/BabySightings/test.htm

class="Link1" isn't working in IE.


Any help appreciated.

jscheuer1
07-01-2006, 05:50 AM
Take care of these first, then see if you still have a problem:

No body section on the page.

No closing </head> tag on page.

No closing </html> tag on page.

Error: Selector expected. Ruleset ignored due to bad selector.
Source File: http://www.sidconcepts.com/BabySightings/anylink.css
Line: 32

Error: Unexpected end of file while searching for closing } of invalid rule set.
Source File: http://www.sidconcepts.com/BabySightings/anylink.css
Line: 32

Error: MM_swapImage is not defined
Source File: http://www.sidconcepts.com/BabySightings/test.htm
Line: 21

Error: MM_swapImgRestore is not defined
Source File: http://www.sidconcepts.com/BabySightings/test.htm
Line: 21

StaceyB
07-01-2006, 03:52 PM
Got it!
.Link1 img {border: 0}