PDA

View Full Version : Fade-in slideshow images displaying white speckles



T0bster
06-28-2006, 05:46 PM
Hi,

I am using your script here:-
http://www.newbondstreetpawnbrokers.com/new/

It's a great script and it was very easy to implement, however I have noticed the car and antique pocketwatch images both show little white speckles on them in IE.

I don't know what is causing this and it only happens in IE, FF displays the images perfectly. All of the images were created using the same options within "save for the web" in Photoshop CS and they are all JPGs.

I searched this forum before posting but was surprised to see nobody had experienced the same problem.

Can you help?

Thanks a lot,
Toby

Twey
06-28-2006, 06:04 PM
I searched this forum before posting but was surprised to see nobody had experienced the same problem.Actually, this has been discussed several times. I think the only solution eventually arrived at was to continually blue the part of the image exhibiting said defects until they didn't show any more.

T0bster
06-29-2006, 08:10 AM
I've just saved the images again with 60% compression (high quality rather than very high quality) and it's definitely reduced the amount of speckles....

http://www.newbondstreetpawnbrokers.com/new/

Twey
06-29-2006, 03:15 PM
Essentially blurring the whole image. :p

T0bster
06-29-2006, 03:18 PM
Is there any other way of achieving the same result? Has anyone tried using GIFs instead?

Twey
06-29-2006, 03:25 PM
GIFs would not cause the same problem, no. I think it's a flaw in IE's JPEG renderer.

The blurring "solution" isn't really a solution at all, it's just trial-and-error, changing pixels around until the problem is no longer triggered. If you can spare the bandwidth, by all means use GIF (or even better, PNG).