PDA

View Full Version : Empty Boxes With Little Red x



NADB
06-22-2006, 02:39 AM
Hi,

My webpage shows fine using my browser but when I asked a couple of friends to view it, all they got were empty boxes with the little red x.

I know the reason my graphics are showing in my browser is because of my graphic files are stored on my computer. The path to my files starts like this:
C:\Documents and Settings\My Documents\My Pictures.

Is there a way to correct this?

Thanks In Advance,
NADB

Iiro
06-22-2006, 05:55 AM
You mean images doesn't view correctly? try this before </head>:
<base href="C:\Documents and Settings\My Documents\My Pictures" />

if above does nothing just move your document to same directory where images are.

djr33
06-22-2006, 06:46 AM
Liro, I don't think that's right.

I think the problem is that you are linking to files that are on your computer, but asking people to view from other computers. You need to put the files on the internet, and link to those paths. If they are on the internet, you need to change the path so it's to the file on the net, not on your hard drive.
Also, you might want to use relative links/urls so that you don't have this issue:
<img src="image.jpg">, where the image is in the same folder as the webpage.

Iiro
06-23-2006, 07:51 AM
??? I thought he was meaning that he wants to locally view that page... UPLOAD YOUR IMAGES TO THE SAME DIRECTORY WEHERE IS YOUR PAGE!!!


Liro, I don't think that's right.

I'm IIRO, lowercase iiro, not Liro

djr33
06-23-2006, 09:52 AM
Oh, sorry about that... lowercase L's and uppercase I's are similar. :)

You may still be right... but I think it's a far simpler problem... sounds like the images just aren't there. We'll see what he says.

NADB
06-24-2006, 08:31 PM
Thanks for the replies Iiro and djr. You are right djr33, the files are on my computer that I would like for other people to view.

I used my website editor to build my website but I had to use this third party editor to publish my site. The reason, I didn't like the templates they provided for a internet store, so I built my own. My domain name was directed to their servers.

When I used there editor to publish my site the text and all of their images <img src="images.jpg"> showed up fine. My webgrapics showed up empty boxes with the red x. I checked the source code. Still showed files linking to my hard drive. C:\Documents and Settings\My Documents\My Pictures.

I am trying to work around it, If I can. Any help would be appreciated.

Thanks In Advance,
NADB
_________________

Knowledge is appreciated the most, when people take the time to share it.

djr33
06-24-2006, 08:37 PM
Um...just upload the images using ftp or your host's default uploader page thing.

That's how you do it..... now.... for more info... not sure about your specific host, I guess.

Why can't you upload them?

NADB
06-24-2006, 08:59 PM
That's the million dollar question. I transfered my template files over to their editor and published. I got the empty boxes.

I asked their technical department about why my graphics didn't show. All they could tell me, make sure that I published my files correctly.

All images inlcuding website graphics show up on my computer. I guess I need to take a look back to make sure I didn't miss anything while uploading using their editor.
_________________

Knowledge is appreciated the most, when people take the time to share it.

djr33
06-24-2006, 09:00 PM
Look back.
But also start relying less on templates and defaults and programs that do it for you.
As you've seen, they'll mess up, and you need to be able to fix it when they do... so... use them as a tool, but not as a crutch. :)

NADB
06-24-2006, 09:06 PM
You are so right!!! Thanks for the knowledge.
_________________

Knowledge is appreciated the most, when people take the time to share it.

djr33
06-25-2006, 12:55 AM
Sure.

And remember... it's like touch typing:

Hunt and peck will work great for a while, and you'll get stuff done. When you start touch typing, you'll be bad, slow, and it'll take forever to learn.
Then you'll start typing 60wpm and wonder what you ever did without it :)

Same with the transition to using html instead of wysiwyg.

mwinter
06-25-2006, 01:05 AM
<base href="C:\Documents and Settings\My Documents\My Pictures" />URIs must not contain backslashes. No matter what the operating system, the path separator in a URI is always a forward slash.

Mike