PDA

View Full Version : Page Load suddenly way slow



Strangeplant
06-12-2006, 05:11 PM
Hi, I badly need your help, please.

I've been using several DD's javascripts on different pages to do what I need, and they worked just perfectly:) .....up until now:( . There is a combination of included and external javascript - it doesn't seem to matter, but the time to load a page is way, way long. (You will see.)

One of the pages that takes a very long time to load is very short html, but uses two external javascript files (making it almost all javascript) is this: http://earth.engr.ccny.cuny.edu/noaa/wc/Lidar/chainedmenu1.html

The main page is a combination of internal and external javascript, and while it loads fairly quickly in IE, it takes literally forever in FF: http://earth.engr.ccny.cuny.edu/noaa/wc (And, yes, I know that I can clean up some of the code, but that isn't the thing dragging it down because it worked speedy enough just a week or two ago.)

The Apache server wasn't compiled right in the beginning, and I couldn't use php and mySQL, so the admin for the server recompiled it, this time with "the latest 4.x version" of php and "the latest version of Apache" on a Sun. Now, php works, SSI's don't anymore. But the real problem is that any page with javascript takes up to two minutes to load on FF, and slow with IE (but much, much faster than FF.):mad: And to make things confusing, just about the same time, the latest version of FF downloaded and installed itself, so I really can't be sure which, or both maybe, is(are) the cause(s).:confused:

If anyone is interested, the system configuration can be viewed here: http://earth.engr.ccny.cuny.edu/noaa/wc/phpTest.php

So, what can I do to improve things on my end? (or) What is the real reason? (or) How can I find out what is wrong on either end to correct things?

A real expert take on this would be greatly appreciated, because this is stumping us both, and we really don't know what to change. I'm tempted to add some php timing script at the head and end to see just how long it takes the server to parse the page, but I don't think that is the issue because the time is not excessive in IE and these pages aren't php anyways.......anyway.....

BTW, I never use smileys....except here. Needless to say, we are not server experts.

Twey
06-12-2006, 05:15 PM
First page loads instantly. Second loads slowly, but it's only about ten seconds, not "literally forever."
Firefox on 10MB/s down connection.

Strangeplant
06-12-2006, 05:21 PM
Well, thanks for telling me this. I never would have thought so, because, then, it must be my machine.....hummm. Wonder what's wrong on my end? (That's the good news), so thanks for checking!

T-B0N3
06-13-2006, 07:08 AM
You should try to access it from another machine. Your OS is probably worn out... for me it loaded quite fast. The second one presented a minor "hick-up" in the beggining but it loaded pretty fast after all (about 10 seconds).