PDA

View Full Version : Problems with Lightbox Viewer 2.0 in Firefox w/custom scrollbars div



logicalinsanity
06-10-2006, 07:09 PM
Hi there...

I was hoping one of you javascript gods out there could help me with a problem I'm having with the Lightbox Image Viewer 2.0 (http://www.dynamicdrive.com/dynamicindex4/lightbox2/index.htm) script.

Specifically, I'm having a problem getting it to work in Firefox when I put my thumbnails within a scolling div area using the FleXscroll script by Heseido (http://www.hesido.com/web.php?page=customscrollbar) - which is a cross-browser, user-friendly custom scrollbar script. BTW, I know custom scrollbars are *bad*...but in this case...it was a specific request by the client. :)

I know I'm not supposed to ask questions about problems with 3rd party scripts...but I was hoping by posting the .js code...someone would take pity on me (plus I wasn't sure if his code qualified as 'complicated'). If I messed up...please don't hollar at me.

I've got an example of the problem set up here (http://vedadesigns.net/phototest/). With the FleXcroll .js code here (http://vedadesigns.net/phototest/flexcrolljs.txt).

In Firefox, the image just opens directly in the browser...bypassing the Lightbox effect. It works correctly in IE though (go figure) - and I haven't tested any other browsers.

Aside from the basics...I'm really quite awful with javascript....so I've no clue on where to start for troubleshooting. I tried scanning through the flexcroll.js file to see if anything obvious popped out at me...but I've really no clue what to look for.

Thanks in advance to anyone who can help.

jscheuer1
06-13-2006, 10:49 PM
I'm thinking you found a solution as, your demo works in FF here.

logicalinsanity
06-22-2006, 05:42 PM
Yup. Sorry about that. I made a mental note to post a follow-up here - but had forgotten. I contacted the script author and he identified the problem right away.

Both scripts (lightbox & flexcroll) require an onload event, so I just had to initiate them both in a function. If I'd actually read through the Lightbox FAQ, they specifically mention this as being a possible problem when you can't get their script to work. Definitely taught me a lesson in doing my homework better before bothering people. :)